本文へ移動
QKQuickKitEN
TCP/IPLOCALブラウザ内で処理

ICMP・ICMPv6 タイプ/コード リファレンス

ICMP(IPv4)と ICMPv6 のメッセージタイプ・コードの検索リファレンス。ICMPv6 のエラー/情報メッセージの区分と、タイプ/コード検索付き。

入力と主要な処理をブラウザ内で行い、その入力内容をQuickKitサーバーへ送信しない設計です。

タイプ/コード検索

ICMP・ICMPv6 タイプ/コード リファレンス表

タイプ名称
ICMPv40

Echo Reply

Echo Request への応答です。ping が受け取るのはこのメッセージです。

RFC 792

ICMPv43

Destination Unreachable

ルーターまたは宛先ホストがデータグラムを届けられなかったことを知らせます。理由はコードで示され、元のパケットの先頭部分が含まれます。

RFC 792

ICMPv43 / 0

Net Unreachable

ルーターが宛先ネットワークへの経路を持っていません。

RFC 792

ICMPv43 / 1

Host Unreachable

宛先ホストに到達できませんでした(最後のルーターがリンク上のホストへ配送できない場合など)。

RFC 792

ICMPv43 / 2

Protocol Unreachable

IP ヘッダーの Protocol フィールドが示すプロトコルを、宛先ホストが扱えません。

RFC 792

ICMPv43 / 3

Port Unreachable

宛先ポートで待ち受けているものがありません(閉じた UDP ポートへの送信など)。

RFC 792

ICMPv43 / 4

Fragmentation Needed and Don't Fragment was Set

次のリンクの MTU より大きいデータグラムに Don't Fragment が設定されていました。RFC 1191 以降は次ホップの MTU が含まれ、Path MTU Discovery はこのメッセージに依存します。

RFC 792, RFC 1191

ICMPv43 / 5

Source Route Failed

ソースルートオプションで指定された次のホップへ、ルーターが転送できませんでした。

RFC 792

ICMPv43 / 6

Destination Network Unknown

宛先ネットワークが存在しないことを示します。RFC 1812 は、ルーターはこのコードを送らず、代わりにコード 0 を使うべきとしています。

RFC 1122

ICMPv43 / 7

Destination Host Unknown

宛先ホストが存在しないことを、ルーターがリンク層の情報から判断した場合に返されます。

RFC 1122

ICMPv43 / 8

Source Host Isolated

送信元ホストが孤立していることを示します。RFC 1812 は、ルーターはこのコードを送らず、コード 0 または 1 を使うべきとしています。

RFC 1122

ICMPv43 / 9

Communication with Destination Network is Administratively Prohibited

宛先ネットワークとの通信が管理上禁止されています。もとは米軍の暗号化装置向けで、RFC 1812 はフィルタするルーターはコード 13 を使うべきとしています。

RFC 1122

ICMPv43 / 10

Communication with Destination Host is Administratively Prohibited

宛先ホストとの通信が管理上禁止されています。もとは米軍の暗号化装置向けで、RFC 1812 はフィルタするルーターはコード 13 を使うべきとしています。

RFC 1122

ICMPv43 / 11

Destination Network Unreachable for Type of Service

要求された Type of Service では、宛先ネットワークに到達できません。

RFC 1122

ICMPv43 / 12

Destination Host Unreachable for Type of Service

要求された Type of Service では、宛先ホストに到達できません。

RFC 1122

ICMPv43 / 13

Communication Administratively Prohibited

管理上のフィルタリングにより、ルーターがパケットを転送できませんでした。送信しない設定にもできるため、フィルタが何も返さずに破棄する場合もあります。

RFC 1812

ICMPv44

Source Quench (deprecated by RFC 6633)

かつて送信元に送信速度を下げるよう求めたメッセージです。RFC 6633 で廃止され、ホストは送信してはならず、受信側は黙って破棄できます。

RFC 792, RFC 6633

ICMPv45

Redirect

同じネットワーク上のホストに対し、一部の通信には別の次ホップのルーターを使うよう、ルーターが知らせます。

RFC 792

ICMPv45 / 0

Redirect Datagram for the Network

宛先ネットワーク全体についてのリダイレクトです。RFC 1812 はルーターがこのコードを送ることを禁じており、ルーターはホスト単位のリダイレクト(コード 1)を送ります。

RFC 792

ICMPv45 / 1

Redirect Datagram for the Host

1 つの宛先ホストについてのリダイレクトです。その宛先への通信は、示されたルーターへ送ります。

RFC 792

ICMPv45 / 2

Redirect Datagram for the Type of Service and Network

宛先ネットワークと Type of Service の組についてのリダイレクトです。RFC 1812 はルーターがこのコードを送ることを禁じています。

RFC 792

ICMPv45 / 3

Redirect Datagram for the Type of Service and Host

宛先ホストと Type of Service の組についてのリダイレクトです。

RFC 792

ICMPv48

Echo Request

宛先に Echo Reply を返すよう求めます。ping が送るのはこのメッセージです。

RFC 792

ICMPv49

Router Advertisement

ホストがデフォルトルーターを見つけられるよう、ルーターがリンク上で自分のアドレスを告知します(ICMP Router Discovery、RFC 1256)。

RFC 1256

ICMPv410

Router Solicitation

ホストがリンク上のルーターに、すぐ Router Advertisement を送るよう求めます(RFC 1256)。

RFC 1256

ICMPv411

Time Exceeded

時間の上限を超えたためデータグラムが破棄されました。TTL が 0 になった場合と、フラグメントの再構成に時間がかかりすぎた場合があります。

RFC 792

ICMPv411 / 0

Time to Live Exceeded in Transit

TTL が 0 になったため、ルーターがデータグラムを破棄しました。traceroute はこのメッセージを利用します。

RFC 792

ICMPv411 / 1

Fragment Reassembly Time Exceeded

すべてのフラグメントが時間内に届かなかったため、宛先が再構成をあきらめました。

RFC 792

ICMPv412

Parameter Problem

ホストまたはルーターが IP ヘッダーに問題を見つけ、データグラムを破棄しました。

RFC 792

ICMPv412 / 0

Pointer indicates the error

Pointer フィールドが、元のヘッダー内で問題のある位置(バイト単位)を示します。

RFC 792

ICMPv412 / 1

Missing a Required Option

必要なオプションがありません。IP セキュリティオプション用に RFC 1108(現在は Historic)で定義されました。

RFC 1108

ICMPv412 / 2

Bad Length

ヘッダー長またはデータグラム長が不正です。

RFC 792

ICMPv413

Timestamp

宛先に時刻のタイムスタンプを返すよう求めます。

RFC 792

ICMPv414

Timestamp Reply

Timestamp 要求への応答で、要求を受信した時刻と応答を送信した時刻を含みます。

RFC 792

ICMPv61

Destination Unreachable

輻輳以外の理由でパケットを届けられなかったことを知らせます。理由はコードで示されます。

RFC 4443 · エラー

ICMPv61 / 0

No route to destination

ルーターに宛先と一致する経路がありません(デフォルトルートもありません)。

RFC 4443 · エラー

ICMPv61 / 1

Communication with destination administratively prohibited

管理上の理由で配送が禁止されています(ファイアウォールのフィルタなど)。

RFC 4443 · エラー

ICMPv61 / 2

Beyond scope of source address

宛先が送信元アドレスのスコープの外にあります(リンクローカルの送信元からグローバルな宛先へ送った場合など)。

RFC 4443 · エラー

ICMPv61 / 3

Address unreachable

その他の理由で配送できませんでした(近隣探索で宛先のリンク層アドレスを解決できない場合など)。

RFC 4443 · エラー

ICMPv61 / 4

Port unreachable

宛先ポートで待ち受けているものがありません(UDP など)。

RFC 4443 · エラー

ICMPv61 / 5

Source address failed ingress/egress policy

送信元アドレスが、入口または出口のフィルタリングポリシーで許可されていません。

RFC 4443 · エラー

ICMPv61 / 6

Reject route to destination

宛先が拒否経路(reject route)に一致しました。

RFC 4443 · エラー

ICMPv62

Packet Too Big

パケットが次のリンクの MTU より大きいことを知らせ、その MTU を含みます。IPv6 のルーターはフラグメント化しないため、Path MTU Discovery はこのメッセージに依存します。

RFC 4443 · エラー

ICMPv63

Time Exceeded

上限を超えたためパケットが破棄されました。Hop Limit が 0 になった場合と、フラグメントの再構成が時間切れになった場合があります。

RFC 4443 · エラー

ICMPv63 / 0

Hop limit exceeded in transit

Hop Limit が 0 になったため、ルーターがパケットを破棄しました。traceroute はこのメッセージを利用します。

RFC 4443 · エラー

ICMPv63 / 1

Fragment reassembly time exceeded

すべてのフラグメントが時間内に届かなかったため、宛先が再構成をあきらめました。

RFC 4443 · エラー

ICMPv64

Parameter Problem

IPv6 ヘッダーまたは拡張ヘッダーのフィールドを処理できませんでした。Pointer がその位置を示します。

RFC 4443 · エラー

ICMPv64 / 0

Erroneous header field encountered

ヘッダーのフィールドに処理できない値があります。

RFC 4443 · エラー

ICMPv64 / 1

Unrecognized Next Header type encountered

Next Header の値を認識できませんでした。

RFC 4443 · エラー

ICMPv64 / 2

Unrecognized IPv6 option encountered

IPv6 のオプションを認識できず、そのオプション種別がこのエラーの通知を求めていました。

RFC 4443 · エラー

ICMPv6128

Echo Request

宛先に Echo Reply を返すよう求めます。ping が送るのはこのメッセージです。

RFC 4443 · 情報

ICMPv6129

Echo Reply

Echo Request への応答です。ping が受け取るのはこのメッセージです。

RFC 4443 · 情報

ICMPv6130

Multicast Listener Query

ルーターが、リンク上で受信者のいるマルチキャストアドレスを問い合わせます(MLD)。

RFC 2710 · 情報

ICMPv6131

Multicast Listener Report

ノードが、あるマルチキャストアドレスを受信していることを報告します(MLDv1)。

RFC 2710 · 情報

ICMPv6132

Multicast Listener Done

ノードが、あるマルチキャストアドレスの受信をやめたことを報告します(MLDv1)。

RFC 2710 · 情報

ICMPv6133

Router Solicitation

ホストがリンク上のルーターに、すぐ Router Advertisement を送るよう求めます(近隣探索)。

RFC 4861 · 情報

ICMPv6134

Router Advertisement

ルーターが自身の存在とプレフィックスなどのリンク情報を告知します。ホストはデフォルトルートやアドレス自動設定(SLAAC)に使います。

RFC 4861 · 情報

ICMPv6135

Neighbor Solicitation

近隣ノードのリンク層アドレスを問い合わせたり、到達可能か確認したり、アドレスの重複を検出(DAD)したりします。

RFC 4861 · 情報

ICMPv6136

Neighbor Advertisement

Neighbor Solicitation に応答します。リンク層アドレスが変わったことを自発的に知らせる場合もあります。

RFC 4861 · 情報

ICMPv6137

Redirect Message

ルーターがホストに、宛先へのより良い最初のホップ、または宛先が同じリンク上にあることを知らせます。

RFC 4861 · 情報

ICMPv6143

Multicast Listener Discovery Version 2 (MLDv2) Report

ノードが、送信元フィルタを含むマルチキャストの受信状態を報告します(MLDv2、RFC 3810)。

RFC 3810 · 情報

仕組みと使い方

IPv4 の ICMP(RFC 792・1122・1191・1256・1812・6633)と ICMPv6(RFC 4443・4861・2710・3810)のメッセージタイプとコードのリファレンスです。コード欄が空の行はタイプ自体を表し、番号付きのコード行はそのタイプ内の 1 つのコードを表します。各行は英語の正式名称を残したうえで、メッセージの意味や用途の短い説明を日本語・英語で添えています。フィルタはどちらの言語の語句にも一致します。タイプ 4(Source Quench)は RFC 6633 で廃止されました。ICMPv6 には明確な数値の規則があります: タイプ 1-127 はエラーメッセージ、128-255 は情報メッセージです(RFC 4443)。ICMPv4 に同等の区分はありません。運用上の注意: ICMP を一律に破棄すると Path MTU Discovery(ICMPv4 タイプ 3 コード 4「Fragmentation Needed」および ICMPv6 タイプ 2「Packet Too Big」)が壊れ、IPv6 では近隣探索(タイプ 133-137)も壊れます。ICMP を丸ごとフィルタするのではなく、少なくともこれらは許可してください。これは IANA レジストリの厳選した抜粋で、正しいと確認できた項目のみを掲載しています。表は JavaScript なしでも表示され、テキストフィルタと検索パネルには JavaScript が必要です。